Problem with checking in

Nov 2, 2016 at 2:49 PM
Edited Jan 18 at 2:34 PM
(18-1-2017 changed to remove private information)
hi all,

I am trying to upload files to an Office365 environment. I am importing documents in an existing folderstructure. The only attribute I specify to the document is the contenttype. There is more metadata, but those are filled using default values for the folders.

The library does not use versioning. There are no files (yet) within any of the folders.

The file is uploaded, but with an error:
" The file https://***** Achterhoek/Bosmanslaan, Dinxperlo/Northwind June Expense Categories.xlsx is checked out for editing by i:0#.f|membership|*****i:0#.f|membership|*****@*****".
(I translated this message for you from Dutch). This is indeed the user account specified in the configuration.xml.

When I try to check in the document afterwards by hand, no errors are given.

Can someone help me out why the document is not checking in?

Thanks in advance.
Nov 3, 2016 at 11:07 AM
It sounds like you are using location defaults to set meta data per folder.

This might be the cause of the problem.

I would suggest the following might help.

1) If there are columns associated with the content type which are mandatory then set these to non-mandatory whilst you run the import.

2) Provide further details of how your import and library are configured (I..e the xml config file, source data set, destination library and content type settings or template of such)

Even if you fix the problem yourself it would be good to know what the cause was so DIFS can be updated.
Marked as answer by TheovB on 11/3/2016 at 5:40 AM
Nov 3, 2016 at 1:39 PM
Using the tips you gave I have done a lot of tests with Managed Metadata Fields. It does not matter if you set a location default or not. It does not matter if you provide the field value using an import mapping or not.

What does matter is the mandatory setting for the field. When mandatory, it fails, when non-mandatory it is successful.

For the import this is a solution I can live with. Thanks for replying in such short notice, MadAboutImport.

By the way: great program. My complements!
Nov 4, 2016 at 3:17 PM
Thank you for the detailed feedback.

Fixed in DIFS 2.5