Problem copying files to SharePoint Online - remote server returned error: (404) Not Found

Oct 29, 2014 at 10:50 PM
I have a SharePoint Online site collection. This site collection has two subsites. I follow the directions in the downloaded PDF file for setting up the connection. When I enter the destination SharePoint site using the Site Collection URL and hit Load, Destination Library box is populated with the correct information. If I select one of the SubSites in the tree view, it throws an error:

Unhandled exception has occurred in your application. If you click Continue, the application will ignore this error and attempt to continue. If you click Quick, the application will close immediately. Object reference not set to an instance of an object.

If I select the Document Library beneath one of the SubSites - no error. All of the other fields appear to be populated with the correct data. However, when I start the Import, it seems to scan all the folders it is preparing for the import. As soon as it gets to the first file to import, it shows a line that says:

ImportRow:D:\Data\FolderA\Filename.pdf:ExceptionThe remote server returned an error: (404) Not Found.

This continues until I cancel the Import. I have attempted to let it run to see if it populates any of the files in SharePoint, but it does not.

Could you offer any suggestions as to what I may be doing wrong, or how to resolve this issue?

Thanks,
Coordinator
Oct 30, 2014 at 2:44 PM
I believe that there is a bug in the library selection. When you have picked your destination look at the text boxes that are populated with the various elements of the url of the document library. You will probably see and be able to correct the fact that those text boxes are populated incorrectly. The import should then work.

At some point that will be fixed, but not today!
Apr 12, 2015 at 7:14 AM
Edited Apr 12, 2015 at 7:21 AM
Hi MadAboutImporter,

I know this is a thankless job and appreciate what you're doing for the community!

I'm having a similar issue as above, and trying to use the work around you mentioned.
Unfortunately I'm not having much luck (may be the fact that its 2am).

Can you please confirm that I'm following your instructions/intent properly?

Test 1: (Success) Able to connect to "root" team site (Office 365) and transfer files.

Test 2: (Failed) Attempted to connect to different site collection

-> Site Location: https://launchmelabs.sharepoint.com/sites/LML/
-> Library Name: Site Graphics
-> Full URL: (confirmed working) https://launchmelabs.sharepoint.com/sites/LML/SiteAssets

Entered Fields:

-> Destination Web URL (Relative): _/sites/lml _ (also tried /sites/lml/ )
-> Destination Folder (Relative): /SiteAssets
-> Destination Server (absolute): https://launchmelabs.sharepoint.com
-> Destination Library Name: Site Assets

Additional Steps:
  1. I can confirm that I have access to the desired site (using admin account.)
  2. I tried to enable logging, but no log file found in the appdata or installed directory within program files. (also ran program as Admin)
Any help you can give for a work around is appreciated.

Thanks,
Jordan
Coordinator
Apr 13, 2015 at 8:49 AM
I think...

-> Destination Web URL (Relative): /sites/lml
-> Destination Folder (Relative): SiteAssets
-> Destination Server (absolute): https://launchmelabs.sharepoint.com
-> Destination Library Name: Site Graphics
Nov 11, 2015 at 11:12 AM
Hi,
same issue for me. I have tried your solution but didn't work :(

Any help is appreciated.

Regards
Coordinator
May 10, 2016 at 11:31 AM
Caused by a problem in MSOnlineClaimsHelper - Fixed in version 2.0